Attention:

Support Rules and Guidelines
Before you post your support topic, please remember to:
  • Read the support forum rules.
  • Check the wiki and use search to see if your problem can be answered there first.
  • Link your board please, and make sure that the problem on your board is visible to guests or provide a test account.
  • Do not post Board Wrappers and CSS unless requested. With a board link, this is not necessary.
  • Be as descriptive as you can and use as many details as possible when describing your problem.
  • Please briefly mark any links to forums that may not be work-safe.
This will help ensure your support issue will be attended to in a quick and efficient manner.

  Add ReplyNew TopicNew Poll

 Permissions
#
So I am trying to hide certain sections from certain member groups but I am at a bit of a loss.

I've easily managed to hide the staff forum but for some reason though the staff forum does not show for the "character group" (and all other non staff groups) the other areas I've hidden from characters are still showing.

I hid the other area int he exact same way so I am a little stumped.

Help please?
PM
#
The problem with hiding forums from characters only is that character isn't an actual member group.

You can only hide things from Members, Admins, Guests, and Validating, if I remember correctly.

Character profiles would be placed under the MEMBER user group.

There's a way to make a new one, but I can't remember how.

signature
user posted image user posted image user posted image
#
    Forum Control --> Permission Masks

    Put in the name of the Permission Mask, in this case, "Character", then hit inherit from one of the other ones to help you out with filling in some of the forum checkmarks so you don't have to do it from scratch. Hit Create after.

    Then, hit Edit once you go back to Permission Masks, finish adjusting the character permission mask for all of the forums that show up in the edit view.

    Once you've finished this, go to Users and Groups, then Manage User Groups, edit your Character usergroup. One of the very top settings should be assigning it a new permission mask. Simply select the Character permission mask, and then save the group settings.

    You should be good to go!
PM
#
QUOTE (multiplicity! @ Sep 9 2017, 11:05 PM)
    Forum Control --> Permission Masks

    Put in the name of the Permission Mask, in this case, "Character", then hit inherit from one of the other ones to help you out with filling in some of the forum checkmarks so you don't have to do it from scratch. Hit Create after.

    Then, hit Edit once you go back to Permission Masks, finish adjusting the character permission mask for all of the forums that show up in the edit view.

    Once you've finished this, go to Users and Groups, then Manage User Groups, edit your Character usergroup. One of the very top settings should be assigning it a new permission mask. Simply select the Character permission mask, and then save the group settings.

    You should be good to go!


Yup, this is exactly what I did. Perhaps I based the character mask on the member one... do you think I should base it on another?
PM
#
    You can always change the individual permissions by editing the permission mask in the same area you create a new one. Simply remove the checkmarks from the forums you don't want the characters to see.
PM
#
QUOTE (multiplicity! @ Sep 10 2017, 04:16 PM)
    You can always change the individual permissions by editing the permission mask in the same area you create a new one. Simply remove the checkmarks from the forums you don't want the characters to see.


Already tried that too. I have no idea why this is not work. Tis frustrating, lol
PM
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:
Share this topic:
« Next Oldest | General Support | Next Newest »

Options Add ReplyNew TopicNew Poll