Add ReplyNew TopicNew Poll

 Long Posts vanishing or BBcode messing up
#
Hello,

So we have a roleplay site and I ran into two issues. One of them is how the use of a lot of bbcode in one post can mess things up if I go back and try to edit said post. I would run then into an issue where my bbcodes for font, size and color are all over the place and disorganised.

The other issue was something we ran into only recently. We have a long topic covering some of our lore and the topic is using some bbcoding and the 'QUOTE' code to quote some of the text. We noticed that every time we try to edit and add an additional paragraph, the text would vanish when submitting it and even during preview. So what I did to fix it for now, is remove the 'Quote' code from the text thinking that this issue could be affected by settings in php.ini, some general limitation or something.

Is there a way this can be fixed?
PM
#
The first problem is a known issue, unfortunately a very difficult one to solve and doesn't affect everyone. We are working on it.

Let me have a copy of the post text if possible so I can see if the second issue is something that is either a bug in the bbcode system, or can be fixed by raising the setting in php.ini once more. We have not changed any settings in there recently, probably in over a year.

signature
email: admin@jcink.com :: blog: John C.
#
Hello John,

Thank you for replying.

I copy-pasted the post into a different thread so I can link you it:
http://santaverdarpg.jcink.net/index.php?act=ST&f=102&t=881

As you can see there, the post is not blank. But if you take it and try to add any large paragraph/text to it, the entire post will appear blank during and after preview. But if you remove the 'Quote' code from the text, you can add the extra text and the post will appear.

PM
#
Thank you. Can you paste the version of it w/ bbcode on http://pastebin.com so I can try adding some text to reproduce this issue.

signature
email: admin@jcink.com :: blog: John C.
#
Hey John. Of course, here's the link to the paste: (Removed)
PM
#
Verdun thank you that was very helpful.

Here is what I have done: adjusted some settings in php.ini to help alleviate this, and I was able to add another paragraph. Please try adding a new paragraph now.

I have also changed the behavior of the post system to block these "blank" posts from ever being saved again. with a copy of the post and error message presented to the user, should this come up in the future. This is an example of the error message before limits were increased. I think this should be the end of "vanishing posts."

I'm tagging in Rosalieart into this to let them know of this update, since they have a ticket in about this issue as well.

Attached 1 File(s)
Attached Image

signature
email: admin@jcink.com :: blog: John C.
#

John, your help and support is really appreciated. Thank you very much!

I was able to add a paragraph to my topic wonderfully, without having to remove the 'quote' code.

PM
#
Thanks for the update!

signature
email: admin@jcink.com :: blog: John C.
#
Fantastic, thanks John!!
PM
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:
Share this topic:
« Next Oldest | Bug Reports | Next Newest »

Options Add ReplyNew TopicNew Poll