ClosedNew TopicNew Poll

 Post count maybe bug? [Fixed]
#
So, I have a website set up where post count directly influences certain things and perks on the site, and there are certain forums where post count doesn't increase.

While testing things on it today I accidentally made a post in the wrong spot and when I deleted it it subtracted a post, which is kind of a problem because it subtracts a post without adding one. I'm pretty sure its not something on my side specific and more something across all forums.
PM
#
I can confirm this is a bug on my site too. Why do I feel like this was something someone addressed before and Jcink didn't have a fix for it?

signature
user posted image
#
It is weird. But it might be because of how the databases are structured.

At the most basic, it should be something like this.
- Check forum to see if post counts increase.
-- If yes, decrease user post count when deleted.
-- If no, leave post count alone.

This should sound easy enough but it all depends on the database structure.
PM
#
QUOTE (GMaster479 @ Apr 30 2017, 01:57 AM)
I can confirm this is a bug on my site too. Why do I feel like this was something someone addressed before and Jcink didn't have a fix for it?


Sometimes things slip through the cracks. If this bug is what I believe it to be, then it should be an easy fix.

signature
email: admin@jcink.com :: blog: John C.
#
AiMakai, GMaster479 it is exactly as I thought it was and it was an easy fix so this would be working now.

I added a check to the subtraction routine to look for increase_postcount or not. If a post is made in a forum with this setting on, and is deleted from said forum, it will not remove the count.

This is NOT retroactive (intentionally) in a sense that if a forum suddenly switches to "no postcount", then past posts that were made if deleted will subtract the count. The opposite is also true.

This will be no problem for you to setup a forum with no-postcount from the get-go though which is what the feature is aimed at. Let me know if it is working now for you as well.

signature
email: admin@jcink.com :: blog: John C.
#
Just following up - does this appear to be solved now?

signature
email: admin@jcink.com :: blog: John C.
#
Yes it is! Thank you very much.

Sorry I didn't respond right away, busy, and thank you for fixing it so quickly http://files.b1.jcink.com/html/emoticons/smile.gif
PM
#
[ This bug has been fixed! ]

Thank you for reporting it to us.

signature
email: admin@jcink.com :: blog: John C.
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:
Share this topic:
« Next Oldest | Bug Reports | Next Newest »

Options ClosedNew TopicNew Poll