Attention:

Support Rules and Guidelines
Before you post your support topic, please remember to:
  • Read the support forum rules.
  • Check the wiki and use search to see if your problem can be answered there first.
  • Link your board please, and make sure that the problem on your board is visible to guests or provide a test account.
  • Do not post Board Wrappers and CSS unless requested. With a board link, this is not necessary.
  • Be as descriptive as you can and use as many details as possible when describing your problem.
  • Please briefly mark any links to forums that may not be work-safe.
This will help ensure your support issue will be attended to in a quick and efficient manner.

  Add ReplyNew TopicNew Poll

 Switch User Menu glitch?
#
Okay I've been fighting this thing for hours.
I'm trying to create a custom navigation bar for my RPG's forum. I was trying to switch the "Jump Chara." Link/button to an image when I noticed that everytime I even clicked the dropdown menu it would ALWAYS kick me back to the control panel for whatever account I was on and wouldn't let me select my secondary profile even just to test. This is repeatedly occurring too. I even stripped the coding down multiple times and it is still behaving abnormally. (View attached image)

Here is the current code

CODE
<span id='sub_bar_2' style="display:none;"><% SUBACCOUNTS %></span><span id='subacct_link_2'><a href='javascript:void(0);'  onclick="document.getElementById('subacct_link_2').innerHTML=document.getElementById('sub_bar_2').innerHTML;">Jump Chara.</a></span>


Has anyone else experienced this same issue? And if so what was your solution? I'm absolutely stumped on this and can't move forward thanks to my incessant need to complete a certain section completely before moving to the next.

I have not gotten very far with skinning this forum so it's still a bit of a mess in the actual board designing so I'm a little reserved about sharing the actual board but if it's absolutely necessary I'll provide it.

Attached 1 File(s)
Attached Image
PM
#
Javascript errors are very difficult to correct without a live page to work from. I know it's kinda weird to share an in-progress project, but it's also very helpful.
PM
#
Understandable, will any other information be required or a test account? Whatever will help so I can move forward I'll gladly comply.

The forum is http://diverseallegory.jcink.net

This post has been edited by LuV: Dec 5 2017, 04:56 PM
PM
#
Yup! We'll need a test account, preferably with at least one sub account.
PM
#
Gotcha!
Account: Bugtester
Password: tester1

If there's anything else please let me know.
PM
#
It appears to be caused because the form is wrapped in this anchor:

CODE
<a href="index.php?act=UserCP" style="float: right; margin-right: 5px; margin-top: 5px;"></a>


Remove the HREF attribute, or remove the anchor, and it should stop loading the UCP.

As a side note: for anchors that don't go anywhere (like the 'jump chara' one you use to load the menu) you don't actually need an HREF attribute of javascript:void(0);. Anchors will still work without an HREF, they just need an additional bit to reapply the a:active styles.

This post has been edited by Dusty: Dec 6 2017, 06:27 PM
PM
#
I feel like a complete and total spazz.
Thank you so much for all the help!
After you pointed out that that coding was the problem I noticed that I had apparently accidentally deleted one of the close tags and after inserting it back in it started working again.
PM
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:
Share this topic:
« Next Oldest | General Support | Next Newest »

Options Add ReplyNew TopicNew Poll