Attention:

Support Rules and Guidelines
Before you post your support topic, please remember to:
  • Read the support forum rules.
  • Check the wiki and use search to see if your problem can be answered there first.
  • Link your board please, and make sure that the problem on your board is visible to guests or provide a test account.
  • Do not post Board Wrappers and CSS unless requested. With a board link, this is not necessary.
  • Be as descriptive as you can and use as many details as possible when describing your problem.
  • Please briefly mark any links to forums that may not be work-safe.
This will help ensure your support issue will be attended to in a quick and efficient manner.

  ClosedNew TopicNew Poll

 Skin looks fine on one board, splits on another [SOLVED]
#
I've been testing a skin on my test board and just now migrated it over to the board it's possibly destined for to see how it'd look with actual subforums and relevant content, but the wrapper breaks in half toward the middle for some reason.

Nothing was changed html/css wise when I moved one to the other, and the HTML templates are exactly as they are on the test forum.

I do know that removing the Forum Row template corrects the issue at the expense of the custom styled content, but I can't narrow things down any further than that.

Test board: http://greensockstest.jcink.net/

Main board: http://goingsouth.jfbs.net/

I even tested it on another forum entirely -- http://forcedheroes.jcink.net -- and it split there, too.

I did just convert the cfs structure to fit the html templates on the test board before I moved the skin over to the main one, but I don't think that would've broken things on one board but not the other.
#
99% sure this is an unclosed div. Please post your forum row html template and category header template.

signature
email: admin@jcink.com :: blog: John C.
#
QUOTE (John @ Dec 3 2016, 08:16 AM)
99% sure this is an unclosed div. Please post your forum row html template and category header template.



CODE
<div class="tableborder category" id="cat-<!-- |cat_id| -->">
<div class='maintitle<!-- |collapsed_class| -->' align='left'>
<span style='float:right;'><a href='#' onclick='catcollapse("<!-- |cat_id| -->");return false;' id='main_<!-- |cat_id| -->'><!-- |collapse_img| --></a>&nbsp;&nbsp;</span>
<{CAT_IMG}><a href="index.php?c=<!-- |cat_id| -->"><!-- |cat_name| --></a></div>
<div id='cat_<!-- |cat_id| -->' style="<!-- |collapsed_style| -->">
    <table width="100%" border="0" cellspacing="1" cellpadding="4">
<% FORUM_ROWS %>
<br>
    </table>
</div>


CODE
<div class='ShinySFtitle'><!-- |name| --></div>

<table cellpadding='0' cellspacing='0'><tr><td><div class='ShinySLeft'><!-- |description| --> <div class='ShinySSub'><!-- |subforums_list| --> <!-- |subforums| --> </div></div></td><td></div>

<div class='ShinySRight'><div class='ShinySBox'><!-- |topics| -->  TOPICS | <!-- |replies| -->  REPLIES</div> <!-- |last_topic| -->  <font size='1'>by</font><br><!-- |last_poster| --><font size='1'>on<br><!-- |last_post| --></font></div></td></tr></table></div>

#
In the first template, add a </div> below the last one. It's wide open.

signature
email: admin@jcink.com :: blog: John C.
#
Added a closing div tag and there was no change. I went to my test board and added a closing tag in the same spot and then the board skin broke there in the same exact manner.
#
Next thing I'm noticing now.

CODE
<table cellpadding='0' cellspacing='0'><tr><td><div class='ShinySLeft'><!-- |description| --> <div class='ShinySSub'><!-- |subforums_list| --> <!-- |subforums| --> </div></div></td><td></div>


I count two div tags here but 3 ending divs. Remove that last </div> after the <td>

signature
email: admin@jcink.com :: blog: John C.
#
There's still no change in the formatting. I did figure out that removing the shinysright div from the forum row template fixes the splitting issue at while breaking everything else, but I know nothing else beyond that.

Here's the wrapper and CSS.

[removed]

This post has been edited by John: Dec 3 2016, 09:58 PM
#
wrapper/css broke the page cause it was too large, so I removed it.

there has to be some kind of open div sucking things up, I'll find it. I don't need the wrappers and css for now. this may take me some time to get to because it isn't jumping out at me at the moment, sorry. at least we did fix those 2 errors regardless.

signature
email: admin@jcink.com :: blog: John C.
#
I don't know if this'll help much, but I glanced over your code and noticed you have extra </div>s that close up the wrapper and innerwrapper ^^;

user posted image

See that light blue highlighted one near the bottom? That one closes #wrapper. The </div> above it (meaning, the </div> above <br />) is closing #innerwrapper. I think your issue may be too many </div>s somewhere or maybe a broken beginning <div>. I'll keep looking, but I wanted to post that before it falls from my mind ;P

----

Update: Yep, those </divs> are definitely the issue.

user posted image

Removed 'em, and everything seems right! http://prntscr.com/df3q3t You tell me though-- It's not like I know your code.

This post has been edited by Foxwells: Dec 4 2016, 12:19 AM
PM
#
QUOTE (Foxwells @ Dec 3 2016, 09:08 PM)
I don't know if this'll help much, but I glanced over your code and noticed you have extra </div>s that close up the wrapper and innerwrapper ^^;

user posted image

See that light blue highlighted one near the bottom? That one closes #wrapper. The </div> above it (meaning, the </div> above <br />) is closing #innerwrapper. I think your issue may be too many </div>s somewhere or maybe a broken beginning <div>. I'll keep looking, but I wanted to post that before it falls from my mind ;P

----

Update: Yep, those </divs> are definitely the issue.

user posted image

Removed 'em, and everything seems right! http://prntscr.com/df3q3t You tell me though-- It's not like I know your code.

Yup, that fixed it! Thanks!

But I'm still confused to no end how the skin was working just fine on one board and not the other. That perplexing as hell since I migrated over everything exactly as it was on the test board, seemingly random tags and all.
#
Sometimes that's just how coding is xD It'll look great in one place, then you move it and it suddenly all just falls apart. I don't really have an explanation for it besides the environmental move revealing bugs that we're visible in the old environment.

Glad I could help! :~)
PM
#
QUOTE (Foxwells @ Dec 4 2016, 02:13 AM)
Sometimes that's just how coding is xD It'll look great in one place, then you move it and it suddenly all just falls apart. I don't really have an explanation for it besides the environmental move revealing bugs that we're visible in the old environment.

Glad I could help! :~)


This is often why we encourage users, whenever possible to do skin and theme development on their actual board. It's pretty simple enough to just create a new skin set, create all new skin set pieces and then work on it quietly that way.

Dev environments are great but there's nothing quite like doing it live. http://files.b1.jcink.com/html/emoticons/cool.gif

signature
email: admin@jcink.com :: blog: John C.
#
This topic has been solved. If you need anymore help please post a new thread. Thanks for choosing Jcink services.

signature
email: admin@jcink.com :: blog: John C.
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:
Share this topic:
« Next Oldest | General Support | Next Newest »

Options ClosedNew TopicNew Poll